EIGRP Preferred Path Manipulation

Rashmi Bhardwaj | Blog,Config & Troubleshoot
Advertisements

Introduction: EIGRP Preferred Path

Inside an EIGRP routing domain, many times there is a need to control the EIGRP route path. For instance in scenarios where we have 2 or more equal path links to the destination and need to configure 1st link as preferred path and rest to perform the backup functionality. Below documentation enlightens on how EIGRP parameters can be tweaked and preferred path selection may be achieved.

EIGRP Preferred Path Manipulation Methods

Some of the EIGRP Preferred Path manipulation methods discussed in this article are:

Though traffic manipulation can be performed via other factors also, some methods will be discussed in this post –

Advertisements

The Above Diagram depicts 2 Routers (R1 and R2) connected via 2 links –
Link 1 = R1 Fa0/0 to R2 Fa0/0
Link 2 = R1 Fa0/1 to R2 Fa0/1

R1 and R2 are running EIGRP and configuration of both Routers is shared below –

Base Configuration of R1 
Hostname R1
interface Loopback0
ip address 192.168.0.1 255.255.255.0
!
Interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.112.1 255.255.255.0
!
router eigrp 1
network 192.168.0.0 0.0.255.255
no auto-summary

Base Configuration of R2
Hostname R2
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.112.2 255.255.255.0
!
router eigrp 1
network 192.168.12.0
network 192.168.112.0
no auto-summary
R2 has 2 equal cost paths to network 192.168.0.0/24 ,  1st from interface fa0/0 and 2nd via interface fa0/1.

Metric for 192.168.0.0/24 from Fa0/0 Interface of R2
The formula considers that only K1 and K3 values (by default) are 1 while K2, K4 and K5 are 0 –
Where K1 = Bandwidth and K3 = Delay
Metric = 256 * {(10^7/min BW) + (Total DLY/10)}
Min BW = minimum BW along the path from fa0/0 of R2 to from Looopback0 of R1
Since Loopback0 of R1 has bandwidth of 8000000 Kbps while Fa0/0 of R2 had Bandwidth of 10000 Kbps, hence min BW will be 10000 Kbps
Total DLY = Sum of Delay along the path from fa0/0 of R2 to from Looopback0 of R1
Since Loopback0 of R1 has delay of 5000 Microseconds while Fa0/0 of R2 has delay of 1000 microseconds, hence Total DLY will be 1000 + 5000 = 6000 Microseconds.
Now,
Metric = 256 * {(10^7/min BW) + (Total DLY/10)}
= 256 * {(10^7/10000) + (6000/10)}
= 256 * {1000 + 600}
= 409600

Metric for 192.168.0.0/24 from Fa0/1 Interface of R2
In this case also, the metric values are same as above leading to
Metric = 256 * {(10^7/min BW) + (Total DLY/10)}
= 256 * {(10^7/10000) + (6000/10)}
= 256 * {1000 + 600}
409600

Now, we will devise below methods to make path via Interface Fa0/0 of R2 the preferred one (Successor) for reaching Loopback 0 (192.168.0.0/24) of R1.The backup (Feasible Successor) will be via Interface Fa0/1 of R2.

EIGRP Preferred Path Manipulation via Bandwidth

As per requirement depicted in the above diagram to make R2 prefer Interface Fa0/0 (Successor) to destination 192.168.0.0/24, Bandwidth parameter (K1 Value) will be tweaked to change path preference.

Once the Bandwidth on Interface is increased from 10000 Kbps to 100000 Kbps, recalculation for network 192.168.0.0/24 is performed on R2 which reduces Metric from interface fa0/0 from 409600 to 179200. From now onwards, traffic destined for network 192.1680.0/24 from R2 will take path via Interface Fa0/0.

EIGRP Preferred Path Manipulation via Delay

As per requirement depicted in the above diagram to make R2 prefer Interface Fa0/0 (Successor) to destination 192.168.0.0/24, Delay parameter (K3 Value) will be tweaked to change path preference.

Once the delay on Interface is decreased from 1000 microseconds to 100 microseconds, recalculation for network 192.168.0.0/24 is performed on R2 which reduces Metric on interface fa0/0 from 409600 to 386560. From now onwards, traffic destined for network 192.1680.0/24 will take path via Interface Fa0/0.

EIGRP Preferred Path Manipulation via Offset List

Offset List – Option 1

For R2 to prefer Interface Fa0/0 (Successor) towards destination 192.168.0.0/24, Offset-List may be configured which henceforth will influence EIGRP path selection by increasing the path metric.

With Offset-list, additional metric will add up for the destination network matching the access list. As shown in the above diagram, the offset list is applied on inbound interface fa0/1 of R2. Access-list 10 matches the learned routes for which metric 1 needs to be added (in this case access list 10 matches network 192.168.0.0/24).This method adds +1 to the calculated metric on R2 for 192.168.0.0/24.The total metric value now becomes 409600 + 1 = 409601.Now the Successor path is via Fa0/0 and Feasible successor will be via fa0/1.

Offset List – Option 2

Offset list can be applied on the outgoing interface of advertising router. In this method,R1 will add Metric 1 for network 192.168.0.0/24 advertised via interface fa0/1 towards R2.By doing so,R2 will learn metric from fa0/0 (409600) and fa0/1 (409601) .Hence the Successor path for R2 is via Fa0/0 and Feasible successor will be via fa0/1.

EIGRP Preferred Path Manipulation via Administrative Distance

As we understand that administrative distance is an important parameter during best path selection, hence this can be incorporated on local router to govern best path selection from 2 or more paths of equal cost.

Above diagram depicts how Administrative distance can be leveraged for best path selection. Under the “Router EIGRP 1” command, we change the EIGRP Administrative Distance from default 90 to 91 for routes received from Source (IP = 192.168.112.1,Wildcard Mask = 0.0.0.0).The command calls access list 1 which matches the subnet 192.168.0.0/24 (Loopback 0 of  R1).This configuration drives R2 to prefer path via interface fa0/0 (Administrative distance = 90) and make it the successor while keeping interface fa0/1 as backup.

Continue Reading:

Redistributed EIGRP Routes not learnt due to same Router ID

Introduction to Administrative Distance

Watch this video for better understanding:

ABOUT THE AUTHOR

Advertisements

Leave a Comment

Your email address will not be published. Required fields are marked *

Shopping Cart
Select your currency
USD United States (US) dollar
Scroll to Top