OSPF ABR LSA 3 Filtering

OPSF LSA Type 3 is used for exchanging inter-area routes between different OSPF areas. We may use filter on ABR either inbound or outbound to filter to control the sharing of the LSA3 between different areas.

We will use the topology below to demonstrate how we can filter the inter-area Type 3 LSA on ABR –

Advertisements

In the topology above R2 is acting as the ABR and has 3 OSPF adjacencies along with router R1, R3 and R4.We have created loopbacks on each router and all are advertised in OSPF domain.

Configuration

R1:

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

interface FastEthernet0/0

ip address 9.9.12.1 255.255.255.0

!

router ospf 1

network 1.1.1.1 0.0.0.0 area 12

network 9.9.12.0 0.0.0.255 area 12

R2:

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

interface FastEthernet0/0

ip address 9.9.12.2 255.255.255.0

!

interface FastEthernet1/0

ip address 9.9.23.2 255.255.255.0

!

interface FastEthernet1/1

ip address 9.9.24.2 255.255.255.0

!

router ospf 2

network 2.2.2.2 0.0.0.0 area 0

network 9.9.12.0 0.0.0.255 area 12

network 9.9.23.0 0.0.0.255 area 23

network 9.9.24.0 0.0.0.255 area 24

R3

interface Loopback0

ip address 3.3.3.3 255.255.255.255

!

interface FastEthernet0/0

ip address 9.9.23.3 255.255.255.0

!

router ospf 23

network 3.3.3.3 0.0.0.0 area 23

network 9.9.23.0 0.0.0.255 area 23

R4

interface Loopback0

ip address 4.4.4.4 255.255.255.255

!

interface FastEthernet0/0

ip address 9.9.24.4 255.255.255.0

!

router ospf 24

network 4.4.4.4 0.0.0.0 area 24

network 9.9.24.0 0.0.0.255 area 24

Currently we see the OSPF neighborship is up on R2 with all three peers.

R2#sh ip ospf nei

Neighbor ID     Pri   State           Dead Time   Address         Interface

1.1.1.1           1   FULL/DR         00:00:36    9.9.12.1        FastEthernet0/0

9.9.23.3          1   FULL/BDR        00:00:39    9.9.23.3        FastEthernet1/0

4.4.4.4           1   FULL/DR         00:00:34    9.9.24.4        FastEthernet1/1

Currently we see all routes from one area are flowing into the other areas as below:

R1#sh ip route ospf

Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP

+ – replicated route, % – next hop override

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets

O IA     2.2.2.2 [110/2] via 9.9.12.2, 00:00:20, FastEthernet0/0

3.0.0.0/32 is subnetted, 1 subnets

O IA     3.3.3.3 [110/3] via 9.9.12.2, 00:00:25, FastEthernet0/0

4.0.0.0/32 is subnetted, 1 subnets

O IA     4.4.4.4 [110/3] via 9.9.12.2, 00:00:25, FastEthernet0/0

9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O IA     9.9.23.0/24 [110/2] via 9.9.12.2, 00:00:25, FastEthernet0/0

O IA     9.9.24.0/24 [110/2] via 9.9.12.2, 00:00:25, FastEthernet0/0

As seen in the output above we are getting all routes 2.2.2.2, 3.3.3.3, & 4.4.4.4 on the router R1 as inter-area routes.

Now let us configure filtering on R2 so we don’t advertise 3.3.3.3 to R1.

R2 

ip prefix-list To_Area12 seq 5 deny 3.3.3.3/32

ip prefix-list To_Area12 seq 10 permit 0.0.0.0/0 le 32

R2(config-router)#area 23 filter-list prefix To_Area12 in

Verification

R2#sh ip ospf 2 | be 12

Area 12

Number of interfaces in this area is 1

Area has no authentication

SPF algorithm last executed 00:01:43.880 ago

SPF algorithm executed 9 times

Area ranges are

Area-filter To_Area12 in

Number of LSA 7. Checksum Sum 0x04799D

Number of opaque link LSA 0. Checksum Sum 0x000000

Number of DCbitless LSA 0

Number of indication LSA 0

Number of DoNotAge LSA 0

Flood list length 0

Now finally let’s check on R1 and we shouldn’t be getting 3.3.3.3 any longer on R1.

R1#sh ip route ospf

Codes: L – local, C – connected, S – static, R – RIP, M – mobile, B – BGP

D – EIGRP, EX – EIGRP external, O – OSPF, IA – OSPF inter area

N1 – OSPF NSSA external type 1, N2 – OSPF NSSA external type 2

E1 – OSPF external type 1, E2 – OSPF external type 2

i – IS-IS, su – IS-IS summary, L1 – IS-IS level-1, L2 – IS-IS level-2

ia – IS-IS inter area, * – candidate default, U – per-user static route

o – ODR, P – periodic downloaded static route, H – NHRP, l – LISP

+ – replicated route, % – next hop override

Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets

O IA     2.2.2.2 [110/2] via 9.9.12.2, 00:06:55, FastEthernet0/0

4.0.0.0/32 is subnetted, 1 subnets

O IA     4.4.4.4 [110/3] via 9.9.12.2, 00:06:55, FastEthernet0/0

9.0.0.0/8 is variably subnetted, 4 subnets, 2 masks

O IA     9.9.23.0/24 [110/2] via 9.9.12.2, 00:06:55, FastEthernet0/0

O IA     9.9.24.0/24 [110/2] via 9.9.12.2, 00:06:55, FastEthernet0/0

The above configuration and verification shows how “Area Filter-List” may be used to perform  LSA 3 Filtering.

Share this:
Advertisements

Related Posts

About The Author

Add Comment

Social Media Auto Publish Powered By : XYZScripts.com
Select your currency
USD United States (US) dollar