Q-IN-Q TUNNELING CONFIGURATION SCENARIO

SCENARIO PURPOSE –

To extend customer VLAN 50 across customer WAN environment from Site A (CPE1) to Site B (CPE2).

Below us the diagram for reference where customer has 2 locations Site A (CPE1) and Site B (CPE2) which need to communicate over service provider network (includes QinQ.SW1 and QinQ.SW2)


q-in-q-tunneling-configuration-scenario

STEP 1 –

Let’s configure the customer switch (CPE1) to put the interface facing the service provider on VLAN 50.

CPE1#sh run int fa0/0
interface FastEthernet0/0
Description CPE1 to QinQ.SW1
Switchport
switchport mode access
switchport access vlan 50
end
CPE1#sh run int vlan 50
interface vlan50
ip address 50.50.50.1 255.255.255.0
end

STEP 2 –

Note – It is considered that before this configuration , both the service provider switches QinQ.SW1 and QinQ.SW2 have been configured to support MTU more than 1500 by issuing “system mtu 1504” command and system has been rebooted to bring this change into effect.

Configure the service provider switch interface facing customer CPE1 device in Q-in-Q mode. Also, we will assign tag of 200.

QinQ.SW1#sh run int fa0/0
interface FastEthernet0/0
Description CPE1 to QinQ.SW1
Switchport
switchport mode access
switchport access vlan 200  ——–  This is referred to as customer tag vlan.
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
end

STEP 3 –

Configure the interfaces between the Service Providers (QinQ.SW1 and QinQ.SW2) with basic trunk.

QinQ.SW1#sh run int fa0/1
interface FastEthernet0/1
Description connected to QinQ.SW2
Switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end
QinQ.SW2#sh run int fa0/1
interface FastEthernet0/1
Description connected to QinQ.SW1
switchport
switchport trunk encapsulation dot1q
switchport mode trunk
end

STEP 4 –

The interface on QinQ.SW2 facing the customer side is assigned the same metro-tag of 200.

QinQ.SW2#sh run int fa0/0
interface FastEthernet0/0
Description CPE2 to CPE1 dot1q
switchport access vlan 200
switchport mode dot1q-tunnel
l2protocol-tunnel cdp
l2protocol-tunnel stp
l2protocol-tunnel vtp
no cdp enable
end

STEP 5 –

Configure the customer equipment (CPE2) to include interface facing the service provider (QinQ.SW2) in VLAN 50.

CPE2#sh run int fa0/0
interface FastEthernet0/0
Description connected to QinQ.SW2
switchport
switchport mode access
switchport access vlan 50
end
CPE2#sh run int vlan 50
interface vlan50
ip add 50.50.50.2 255.255.255.0
end
Let’s see what happens when we ping from CPE1 to CPE2.
CPE1#ping 50.50.50.2
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 50.50.50.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/10/12 ms
CPE1#
To summarize , Vlan 50 traffic generating from either of CPE1 or CPE2 (customer location) is double encapsulated with Vlan tag 200 i.e. VLAN 50 is encapsulated in VLAN 200 and sent across over service provider links via q-in-q tunneling.

Please follow and like us:
error

Tags:

Related Posts

Add Comment

Social Media Auto Publish Powered By : XYZScripts.com
Select your currency
USD United States (US) dollar

Checkout : E-STORE for latest release "JNCIP-SEC & JNCIA-SEC Interview Q&A " Dismiss