BGP Scenario Question on specific Route to form eBGP neighborship on loopbacks instead of default route

Based on the experience of how BGP behaves, we have come across many topology related interview questions which we will keep discussing in upcoming posts.One such topological interview question is based on the below topology:

Question as follows:


We have two routers directly connected in different AS i.e. R1 is in AS 100 and R2 in AS 200.We can ping the loopback of R1 from R2 and vice-versa.Now when we try to form EBGP neighborship between R1 and R2 it doesn’t come up.

Lab Setup

R1  Config

interface FastEthernet0/0

ip address 9.9.12.1 255.255.255.0

!

interface Loopback0

ip address 1.1.1.1 255.255.255.255

!

router bgp 100

bgp log-neighbor-changes

neighbor 2.2.2.2 remote-as 200

neighbor 2.2.2.2 update-source Loopback0

neighbor 2.2.2.2 ebgp-multihop 2

!
ip route 0.0.0.0 0.0.0.0 9.9.12.2

R2 Config

interface FastEthernet0/0

ip address 9.9.12.2 255.255.255.0

!

interface Loopback0

ip address 2.2.2.2 255.255.255.255

!

router bgp 200

bgp log-neighbor-changes

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 update-source Loopback0

neighbor 1.1.1.1 remote-as 100

neighbor 1.1.1.1 ebgp-multihop 2

!

ip route 0.0.0.0 0.0.0.0 9.9.12.1

 

Verification:

Ping from R1 to R2:

R1#ping 2.2.2.2

Type escape sequence to abort.

Sending 5, 100-byte ICMP Echos to 2.2.2.2, timeout is 2 seconds:

!!!!!

Success rate is 100 percent (5/5), round-trip min/avg/max = 32/45/60 ms

R2#sh ip bgp summary

BGP router identifier 2.2.2.2, local AS number 200

BGP table version is 1, main routing table version 1

Neighbor        V      AS    MsgRcvd   MsgSent   TblVer  InQ OutQ     Up/Down     State/PfxRcd

1.1.1.1         4          100           0                 0               1              0       0              never             Idle

We see in the output above that R1 can reach R2’S loopback but still we can’t form the BGP neighbor ship over the loopback with R2 though we used update-source loopback as well.

The reason behind such behavior is that we have reachability of the two loopback over the default route. In BGP we need a specific route or a summary route to the neighbor IP to form the BGP neighbor ship.

Now we see as soon as we add a specific route on both the routers towards there loopback we see the neighbor ship gets formed.

R1(config)#ip route 2.2.2.2 255.255.255.255 9.9.12.2

R2(config)#ip route 1.1.1.1 255.255.255.255 9.9.12.1

R1#sh ip bgp summary

BGP router identifier 1.1.1.1, local AS number 100

BGP table version is 1, main routing table version 1

Neighbor        V    AS      MsgRcvd    MsgSent   TblVer     InQ OutQ     Up/Down         State/PfxRcd

2.2.2.2         4         200      5                   5                      1              0       0           00:01:18                 0

We see above the BGP neighborship comes up as we configure the specific static routes.

Please follow and like us:

Add Comment

Social Media Auto Publish Powered By : XYZScripts.com
Select your currency
USD United States (US) dollar

Checkout : E-STORE for latest release "Palo Alto Firewall Interview Q&A " Dismiss