Table of Contents
When comparing Cisco and HP (Hewlett Packard) VLAN configuration, there are some key differences, especially because Cisco uses its IOS and HP typically uses either ProCurve OS or Aruba OS (depending on the model).
This post will provide step by step difference of Cisco and HP Layer 3 CLI configuration.
How VLAN Configuration differs between the two?
Here’s a comparison of how VLANs are configured on both platforms:
1. VLAN Creation
Cisco IOS:
In Cisco, you create VLANs in global configuration mode.
Switch# configure terminal
Switch(config)# vlan 10
Switch(config-vlan)# name Marketing
Switch(config-vlan)# exit
Explanation:
vlan 10
creates VLAN 10.name Marketing
assigns a name to the VLAN.
HP ProCurve OS (or Aruba OS):
On HP switches, the VLAN creation command is different.
Switch(config)# vlan 10
Switch(vlan-10)# name "Marketing"
Explanation:
vlan 10
creates VLAN 10.name "Marketing"
assigns a name to the VLAN.
2. Assigning a VLAN to an Interface
Cisco IOS:
Assigning a VLAN to an interface on Cisco involves setting the port in access or trunk mode.
Switch# configure terminal
Switch(config)# interface gigabitEthernet 0/1
Switch(config-if)# switchport mode access
Switch(config-if)# switchport access vlan 10
Explanation:
switchport mode access
sets the port as an access port.switchport access vlan 10
assigns the interface to VLAN 10.
HP ProCurve OS (or Aruba OS):
On HP, VLAN assignment to an interface is handled with a different command set. HP switches do not use the concept of switchport mode, but you directly tag or untag the VLAN on a port.
Switch(config)# interface 1
Switch(config-if)# untagged 1 vlan 10
- Explanation:
untagged 1 vlan 10
assigns VLAN 10 as an untagged (access) VLAN for port 1. In HP terms, untagged means an access port.- To tag a VLAN on a trunk port, use
tagged
instead ofuntagged
.
3. Trunk Mode Configuration
Cisco IOS:
To configure a trunk port on Cisco:
Switch# configure terminal
Switch(config)# interface gigabitEthernet 0/1
Switch(config-if)# switchport mode trunk
Switch(config-if)# switchport trunk allowed vlan 10,20,30
Explanation:
switchport mode trunk
sets the port in trunk mode.switchport trunk allowed vlan 10,20,30
allows VLANs 10, 20, and 30 on the trunk.
HP ProCurve OS (or Aruba OS):
On HP, trunking is configured by tagging VLANs on interfaces.
Switch(config)# interface 1
Switch(config-if)# tagged 1 vlan 10
Switch(config-if)# tagged 1 vlan 20
Switch(config-if)# tagged 1 vlan 30
Explanation:
tagged
assigns VLANs to the interface in trunk mode. You can tag multiple VLANs on the same interface.- HP does not use the term “trunk mode” as Cisco does. Instead, ports are either tagged or untagged in VLANs.
4. VLAN Deletion
Cisco IOS:
To delete a VLAN in Cisco:
Switch# configure terminal
Switch(config)# no vlan 10
HP ProCurve OS (or Aruba OS):
Deleting a VLAN in HP is done similarly.
Switch(config)# no vlan 10
5. Verification
Cisco IOS:
To verify VLAN configuration on Cisco, you use:
Switch# show vlan brief
HP ProCurve OS (or Aruba OS):
On HP, the verification command is slightly different:
Switch# show vlan
6. VLAN Trunking Protocol (VTP) vs GVRP
Cisco IOS:
Cisco uses VTP (VLAN Trunking Protocol) to propagate VLAN configurations across multiple switches.
Switch(config)# vtp mode server
Switch(config)# vtp domain example
Explanation:
- VTP helps dynamically propagate VLAN configurations.
HP ProCurve OS (or Aruba OS):
HP switches use GVRP (GARP VLAN Registration Protocol) for VLAN propagation.
Switch(config)# gvrp
Switch(config)# interface 1
Switch(config-if)# gvrp enable
Explanation:
- GVRP is an alternative to VTP, and it enables dynamic VLAN registration across switches.
Key Differences Summarized
- Tagged vs Untagged: HP switches do not use the terms access and trunk. Instead, ports are either tagged (trunked) or untagged (access) in VLANs.
- Command Syntax: Cisco uses commands like
switchport mode
, while HP uses the simpler syntax of tagging or untagging ports. - VLAN Propagation: Cisco uses VTP, while HP uses GVRP for dynamic VLAN management.
- Trunking: Cisco uses explicit trunk mode commands, whereas HP switches tag VLANs directly to enable trunking.
Cisco vs HP VLAN Configuration: Layer 2 & Layer 3 VLANs
The table below shows how both Cisco and HP Layer 3 Switch configure Layer 2 and Layer 3 VLANs –
Important Pointers:
- As seen from the above configuration, HP does not implement a separate VLAN interface for Layer 3 configuration.
- Also, prerequisite for Cisco and HP L3 Switch to perform routing is to configure “IP Routing” in configuration mode.
Continue Reading:
Cisco vs Dell VLAN Configuration
Configuring Connectivity Between Ghost Server & Client Across VLANs
ABOUT THE AUTHOR
I am here to share my knowledge and experience in the field of networking with the goal being – “The more you share, the more you learn.”
I am a biotechnologist by qualification and a Network Enthusiast by interest. I developed interest in networking being in the company of a passionate Network Professional, my husband.
I am a strong believer of the fact that “learning is a constant process of discovering yourself.”
– Rashmi Bhardwaj (Author/Editor)