Scenario on BGP Route Reflector Configuration

Rashmi Bhardwaj | Blog,BUZZ
Advertisements

While configuring iBGP neighborship between BGP speaking neighbors in same AS, administrators need to be careful of iBGP rule (BGP Split Horizon) of preventing routing Loops. The rule Governs that “for Route advertisements between IBGP peers, routes learnt via IBGP are never propagated to other IBGP peers.In order to address the Split Horizon rule iBGP neighbors need to be configured in full mesh .

The formula to compute the number of sessions required for a full mesh is n * (n – 1)/2, where n is the number of BGP-enabled devices

Because of the internal BGP (IBGP) full-mesh requirement, most networks use Route Reflectors to simplify configuration. BGP Confederation is another mechanism to eliminate full mesh .

Advertisements

This article will showcase only Route Reflector configuration and how it eliminates the Full mesh iBGP neighbour requirement.

Below Diagram shows the configuration between BGP speaking neighbors across 3 Sites with AS 1, AS 24 and AS 5.

scenario-on-bgp-route-reflector-configuration

The basic configuration is given below –

(R1 configuration)
interface Loopback0
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
router bgp 1
network 1.1.1.0 mask 255.255.255.0
network 192.168.12.0
neighbor 192.168.12.2 remote-as 24
no auto-summary
(R2 configuration)
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0
!
router bgp 24
network 2.2.2.0 mask 255.255.255.0
network 192.168.12.0
network 192.168.23.0
neighbor 192.168.12.1 remote-as 1
neighbor 192.168.23.3 remote-as 24
neighbor 192.168.23.3 next-hop-self
no auto-summary
(R3 configuration)
interface Loopback0
ip address 3.3.3.3 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.3 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.23.3 255.255.255.0
!
router bgp 24
network 3.3.3.0 mask 255.255.255.0
network 192.168.23.0
network 192.168.34.0
neighbor 192.168.23.2 remote-as 24
neighbor 192.168.23.2 next-hop-self
neighbor 192.168.34.4 remote-as 24
neighbor 192.168.34.4 next-hop-self
no auto-summary
(R4 configuration)
interface Loopback0
ip address 4.4.4.4 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.34.4 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.45.4 255.255.255.0
!
router bgp 24
network 4.4.4.0 mask 255.255.255.0
network 192.168.34.0
network 192.168.45.0
neighbor 192.168.34.3 remote-as 24
neighbor 192.168.34.3 next-hop-self
neighbor 192.168.45.5 remote-as 5
no auto-summary
(R5 configuration)
interface Loopback0
ip address 5.5.5.5 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.45.5 255.255.255.0!
router bgp 5
network 5.5.5.0 mask 255.255.255.0
network 192.168.45.0
neighbor 192.168.45.4 remote-as 24
no auto-summary

Now lets see whether all the routes are being learnt by BGP neighbors –

Output on Router R4 shows its iBGP neighbour R3 is not advertising iBGP learnt routes further to R4 (due to BGP Split Horizon Rule) –

R4#sh ip bgp
BGP table version is 31, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incompleteNetwork Next Hop Metric LocPrf Weight Path
*>i3.3.3.0/24 192.168.34.3 0 100 0 i
*> 4.4.4.0/24 0.0.0.0 0 32768 i
*> 5.5.5.0/24 192.168.45.5 0 0 5 i
*>i192.168.23.0 192.168.34.3 0 100 0 i
* i192.168.34.0 192.168.34.3 0 100 0 i
*> 0.0.0.0 0 32768 i
* 192.168.45.0 192.168.45.5 0 0 5 i
*> 0.0.0.0 0 32768 i

Same is the case with R2 where R3 is not further advertising iBGP learnt routes to R2 due to default behaviour of Split Horizon.

R2#sh ip bgp
BGP table version is 25, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incompleteNetwork Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 192.168.12.1 0 0 1 i
*> 2.2.2.0/24 0.0.0.0 0 32768 i
*>i3.3.3.0/24 192.168.23.3 0 100 0 i
* 192.168.12.0 192.168.12.1 0 0 1 i
*> 0.0.0.0 0 32768 i
* i192.168.23.0 192.168.23.3 0 100 0 i
*> 0.0.0.0 0 32768 i
*>i192.168.34.0 192.168.23.3 0 100 0 i

Now, lets configure Route Reflector on R3 and make R2 and R4 as RR clients as below –

R3(config)#router bgp 24
R3(config-router)#neighb 192.168.23.2 route-reflector-client
R3(config-router)#neighb 192.168.34.4 route-reflector-client

Verification on R4 is below –

R4#sh ip bgp
BGP table version is 38, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incompleteNetwork Next Hop Metric LocPrf Weight Path
*>i1.1.1.0/24 192.168.23.2 0 100 0 1 i
*>i2.2.2.0/24 192.168.23.2 0 100 0 i
*>i3.3.3.0/24 192.168.34.3 0 100 0 i
*> 4.4.4.0/24 0.0.0.0 0 32768 i
*> 5.5.5.0/24 192.168.45.5 0 0 5 i
*>i192.168.12.0 192.168.23.2 0 100 0 i
*>i192.168.23.0 192.168.34.3 0 100 0 i
* i192.168.34.0 192.168.34.3 0 100 0 i
*> 0.0.0.0 0 32768 i
* 192.168.45.0 192.168.45.5 0 0 5 i
*> 0.0.0.0 0 32768 i

As shown from “show ip bgp” output on R4 , now its learning iBGP networks (1.1.1.0/24,2.2.2.0/24 and 192.168.12.0/24) from RR ie R3

R2#sh ip bgp
BGP table version is 38, local router ID is 2.2.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incompleteNetwork Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 192.168.12.1 0 0 1 i
*> 2.2.2.0/24 0.0.0.0 0 32768 i
*>i3.3.3.0/24 192.168.23.3 0 100 0 i
*>i4.4.4.0/24 192.168.34.4 0 100 0 i
*>i5.5.5.0/24 192.168.34.4 0 100 0 5 i
* 192.168.12.0 192.168.12.1 0 0 1 i
*> 0.0.0.0 0 32768 i
* i192.168.23.0 192.168.23.3 0 100 0 i
*> 0.0.0.0 0 32768 i
*>i192.168.34.0 192.168.23.3 0 100 0 i
*>i192.168.45.0 192.168.34.4 0 100 0 i

As shown from “show ip bgp” output on R2 , now its learning iBGP networks (4.4.4.0/24,5.5.5.0/24 and 192.168.45.0/24) from RR ie R3.

Hope this BGP Route reflector configuration scenario helped our viewers ?

ABOUT THE AUTHOR

Advertisements

Leave a Comment

Your email address will not be published. Required fields are marked *

Shopping Cart
Select your currency
USD United States (US) dollar
Scroll to Top