Troubleshooting EIGRP Route Advertisement
Redistribution across IGP and BGP is a common scenario especially when we have WAN and LAN communication happening. One example includes Service provider providing WAN link on BGP and customer using IGP like EIGRP in LAN environment.
However, let’s understand what happens when EIGRP redistributes default route into BGP. In case default route not being advertised into BGP, how can the requirement condition for BGP to learn default route be met.
Scenario: EIGRP Learnt Default Route not being advertised into BGP
A lab scenario has been created below –
Below is the basic configuration of R1, R2 and R3 –
R1#
ip address 1.1.1.1 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.1 255.255.255.0
!
router eigrp 1
redistribute static metric 1000 100 255 1 1500 >>>>>> Configured to redistribute default route into EIGRP
network 1.1.1.0 0.0.0.255
network 192.168.12.0
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Null0 >>>>>> A Default Route is injected towards NULL0 for testing purpose
ip address 2.2.2.2 255.255.255.0
!
interface FastEthernet0/0
ip address 192.168.12.2 255.255.255.0
!
interface FastEthernet0/1
ip address 192.168.23.2 255.255.255.0
!
router eigrp 1
network 192.168.12.0
no auto-summary
!
router bgp 1
no synchronization
bgp log-neighbor-changes
network 2.2.2.0 mask 255.255.255.0
network 192.168.23.0
neighbor 192.168.23.3 remote-as 2
neighbor 192.168.23.3 soft-reconfiguration inbound
ip address 192.168.23.3 255.255.255.0
!
router bgp 2
no synchronization
bgp log-neighbor-changes
network 192.168.23.0
neighbor 192.168.23.2 remote-as 1
neighbor 192.168.23.2 soft-reconfiguration inbound
no auto-summary
R2(config-router)#redistribute eigrp 1
R3#show ip bgp
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete
Network Next Hop Metric LocPrf Weight Path
*> 1.1.1.0/24 192.168.23.2 409600 0 1 ?
*> 2.2.2.0/24 192.168.23.2 0 0 1 i
*> 192.168.12.0 192.168.23.2 0 0 1 ?
* 192.168.23.0 192.168.23.2 0 0 1 i
Next , we will include “Default-originate” keyword on R2 and view the output on R3 –
R2(config-router)#neighb 192.168.23.3 default-originate
Status codes: s suppressed, d damped, h history, * valid, > best, i – internal,
r RIB-failure, S Stale
Origin codes: i – IGP, e – EGP, ? – incomplete
Network Next Hop Metric LocPrf Weight Path
*> 0.0.0.0 192.168.23.2 0 0 1 i
*> 1.1.1.0/24 192.168.23.2 409600 0 1 ?
*> 2.2.2.0/24 192.168.23.2 0 0 1 i
*> 192.168.12.0 192.168.23.2 0 0 1 ?
* 192.168.23.0 192.168.23.2 0 0 1 i
*> 0.0.0.0 0 32768 i
Continue Reading:
Redistributed EIGRP Routes not learnt due to same Router ID
EIGRP vs OSPF : Know the difference
ABOUT THE AUTHOR
I am here to share my knowledge and experience in the field of networking with the goal being – “The more you share, the more you learn.”
I am a biotechnologist by qualification and a Network Enthusiast by interest. I developed interest in networking being in the company of a passionate Network Professional, my husband.
I am a strong believer of the fact that “learning is a constant process of discovering yourself.”
– Rashmi Bhardwaj (Author/Editor)